نحوه کانفیگ پروتکل RIP در سیسکو

جدول سرفصل محتوا نحوه کانفیگ پروتکل RIP در سیسکو

من اشکان پزشکی کارشناس تیم فنی شرکت پردیس پارس، در این مقاله قصد دارم در مورد پروتکل RIP و کانفیگ آن در سوئیچ های سیسکو آموزش های لازم را ارائه نمایم. شرکت پردیس پارس مجری خدمات شبکه در زمینه مجازی سازی شبکه، خدمات میکروتیک، خدمات مانیتورینگ شبکه، راه اندازی بکاپ سرور، سرویس های مایکروسافتی، پشتیبانی شبکه، راه اندازی فایروال و نصب و راه اندازی سیسکو می باشد.

پروتکل RIP و کانفیگ آن در سوئیچ های سیسکو:

پروتکل (RIP (Routing Information Protocol یکی از قدیمی ترین پروتکل های روتینگ می باشد که به صورت Distance Vector کار می کند. این پروتکل از ایجاد Loop از مسیر مبدا به مقصد جلوگیری کرده و با پیاده سازی محدودیت روی تعداد HOP ها این کار را انجام می دهد. بیشینه تعداد HOP ها 15 عدد می باشد. این محدودیت بیانگر تعداد HOP ی می باشد که این پروتکل می تواند در یک شبکه پشتیبانی کند. یک Hop count به اندازه 16 عدد برای مسافتی با اندازه ی بی نهایت در نظر گرفته می شود که عملا route غیرقابل دسترس می باشد. پیاده سازی RIP با مکانیزم های Hold down و route poisoning و split horizon باعث می شود از routing information جلوگیری شود.
هر RIP Route آپدیت ها را 30 ثانیه به 30 ثانیه منتقل می کند. در توسعه های اولیه این پروتکل routing table ها آنقدر کوچک بودند که ترافیک قابل توجهی را منتقل نمی کردند. از زمانی که اندازه شبکه ها بزرگ شد مشخص گردید ترافیک های قابل توجه و بزرگی هر 30 ثانیه تولید می شود. پس بنابراین زمان آپدیت 30 ثانیه ای در نظر گرفته شد.
پروتکل RIP از UDP استفاده کرده و شماره پورت رزرو شده برای آن 520 می باشد.


RIP Ver.1:

مشخصات اصلی RIP V.1 به شرح زیر می باشد:
در RFC1058 تعریف شده است و در سال 1988 عمومی گردیده است و به صورت Classful مورد استفاده قرار میگرفت. در این نسخه از پروتکل RIP در دوره های مشخص زمانی بروز رسانی روترها، اطلاعات مربوط به Subnet ها منتقل نمی شد.در این نسخه VLSMپشتیبانی نمی شود. این محدودیت باعث می شود در شبکه هایی که دارای Subnetهای مختلفی هستند نتوان از این Routing Protocol استفاده کرد. همچنین امکان Authentication روترها در این پروتکل وجود نداشته و این نقض باعث میشود تهدیدات امنیتی بسیار جدی ایجاد شود.


RIP Ver.2:

مشخصات اصلی RIP V.2 به شرح زیر می باشد:
در سال 1993 توسعه پیدا کرده و آخرین استانداردسازی آن در سال 1998 بوقوع پیوست. قابلیت جابجایی اطلاعات Subnet ها در این نسخه بوجود آمده است. بنابراین قابلیت های Classless را پشتیبانی می نماید. (Classless Inter-Domain Routing (CIDR
برای حفظ سازگاری محدودیت 15 عدد hop count باقی مانده است. RIP نسخه دوم همانند نسل پیشین خود دارای قابلیت های ساده ای بوده مانند جلوگیری از انتقال بارهای غیرضروری بر روی هاست ها در مسیریابی هایی که وجود ندارند. این نسخه Routing table خود را با روترهای مجاورش روی آی پی آدرس 224.0.0.9 مالتی کست میکند. Authentication برای RIP در سال 1997 معرفی شد.
Route Tag اضافه شده در RIP نسخه دوم این قابلیت را ایجاد کرده است که تمایزی ایجاد شود بین Routeهایی که از یک RIP Protocol آموزش- learn -میبینند و Routeهایی که از بقیه پروتکل ها Learn میکنند.
پروتکل RIP در یک نگاه :

CommentRIP V2Features
 Hop CountMetric
زمان های آپدیتYes (30 seconds)Sends periodic updates
آپدیت ها به صورت فول انجام میشود و بر اساس تغییرات آپدیت ارسال نمی شودFullFull or partial routing updates
آپدیت ها به کجا ارسال می شود؟(224.0.0.9)Where updates are sent
آدرس غیرقابل دسترسی16Metric considered to be “infinite”
 NoSupports unequal-cost load balancing

سناریو تعریف شده در Packet tracer:

توضیحات این سناریو:

(1841Router0) Hostname R1 :

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface fastethernet 0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface serial 0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#bandwidth 64

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

R1(config)#router rip

R1(config-router)#network 10.0.0.0

R1(config-router)#network 20.0.0.0

R1(config-router)#exit

R1(config)#

(2620XM-Router1) Hostname R2:

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface serial 0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

R2(config-if)#exit

R2(config)#interface fastethernet 0/0

R2(config-if)#ip address 30.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config)#router rip

R2(config-router)#network 20.0.0.0

R2(config-router)#network 30.0.0.0

R2(config-router)#exit

R2(config)#

(2621XM-Router2)Hostname R3

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface fastethernet 0/0

R3(config-if)#ip address 30.0.0.2 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#interface serial 0/0

R3(config-if)#ip address 40.0.0.1 255.0.0.0

R3(config-if)#clock rate 64000

R3(config-if)#bandwidth 64

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0, changed state to down

R3(config-if)#exit

%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

R3(config)#router rip

R3(config-router)#network 30.0.0.0

R3(config-router)#network 40.0.0.0

R3(config-router)#exit

#(R3(config

(2811Router3) Hostname R4:

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#interface serial 0/0/0

Router(config-if)#ip address 40.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#interface fastethernet 0/0

Router(config-if)#ip address 50.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

R4(config)#router rip

R4(config-router)#network 40.0.0.0

R4(config-router)#network 50.0.0.0

R4(config-router)#exit

#(R4(config

PC-0

PC>ipconfig

IP Address………………….: 10.0.0.2

Subnet Mask…………………: 255.0.0.0

Default Gateway……………..: 10.0.0.1

PC>ping 50.0.0.2

:Pinging 50.0.0.2 with 32 bytes of data

Reply from 50.0.0.2: bytes=32 time=156ms TTL=124

Reply from 50.0.0.2: bytes=32 time=127ms TTL=124

Reply from 50.0.0.2: bytes=32 time=156ms TTL=124

Reply from 50.0.0.2: bytes=32 time=140ms TTL=124

:PC-1

PC>ipconfig

IP Address………………….: 50.0.0.2

Subnet Mask…………………: 255.0.0.0

Default Gateway……………..: 50.0.0.1

PC>ping 10.0.0.2

:Pinging 10.0.0.2 with 32 bytes of data

 Reply from 10.0.0.2: bytes=32 time=140ms TTL=124

Reply from 10.0.0.2: bytes=32 time=141ms TTL=124

Reply from 10.0.0.2: bytes=32 time=157ms TTL=124

Reply from 10.0.0.2: bytes=32 time=156ms TTL=124

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *